Ejemplos de diagramas de flujo

Solo disponible en BuenasTareas
  • Páginas : 3 (702 palabras )
  • Descarga(s) : 0
  • Publicado : 27 de noviembre de 2011
Leer documento completo
Vista previa del texto
Ejercicio No: 13 Desarrolle un algoritmo para la empresa Constructora Tecnovivir Casas C.A., que le permita calcular e imprimir la nómina para su cancelación a un total de 50 obreros calificados aquienes debe cancelar por horas trabajadas. La hora trabajada se pautó en 30.000 Bolívares. |
Pseudocódigo | Diagrama de Flujo |
1. Inicio 2. Declaración de Variables: Numero_Obreros =50Numero_Hora_Trabajadas = 0 Total_nomina = 0 3. Imprimir líneas de títulos de la nómina 4. Leer Datos 5. Mientras Numero _Obreros>0 6. Salario = Numero_Hora_Trabajada * 30 7. Total_nómina=Totalnómina + Salario 8. Numero_Obreros = Numero_Obreros - 1 9. Imprimir Registro 10. Leer Datos 11. Fin_Mientras 12. Imprimir “Total : “, Total_nómina 13. Fin | si
si
no
noNumero_obreros=numero_obreros-1
Numero_obreros=numero_obreros-1
registro
registro
Numero_obreros>0
Numero_obreros>0
Numero_obreros=50 total_nomina=0
numero_horas_trbajadas=0

,lllNumero_obreros=50 total_nomina=0
numero_horas_trbajadas=0

,lll
inicio
inicio
fin
fin
Total_nomina
Total_nomina
retorno
retorno
datos
datos
Total_nomina=total_nomina+salarioTotal_nomina=total_nomina+salario
Salario=numero_hora_trabajada*30000
Salario=numero_hora_trabajada*30000
Datos
Datos
titulos
titulos
|
Ejercicio No: 14 Desarrolle un algoritmo que funcione como cajaregistradora |
Pseudocódigo | Diagrama de Flujo |
1. Inicio 2. Declaración de Variables: Sub_total=0,Total = 0 3. Ingrese “Código de Producto y Precio:” 4. Almacenar Codigo_Producto, Precio 5.Imprimir líneas de títulos del recibo de pago 6. Mientras Código_Producto “ “ 7. Subtotal = Subtotal + Precio 8. Imprimir Codigo_Producto, Precio 9. Ingrese “Código de Producto yPrecio:” 10. Fin_Mientras 11. IVA = Subtotal * 0,15 12. Total = Subtotal + IVA 13. Imprimir “Sub Total : “, Subtotal 14. Imprimir “ IVA : “, IVA 15. Imprimir “Total: “, Total 16. Fin...
tracking img