Estructuras dinamicas: pilas implementadas con arrays

Solo disponible en BuenasTareas
  • Páginas : 3 (714 palabras )
  • Descarga(s) : 0
  • Publicado : 29 de septiembre de 2010
Leer documento completo
Vista previa del texto
Facultad de Ingeniería Civil, Sistemas y Arquitectura
ESCUELA PROFESIONAL DE INGENIERIA DE SISTEMAS


Pilas

ASIGNATURA :

Algoritmos y Estructura de datos



Ciclo :2009 - II


Lambayeque, Junio del 2010
SIMULACIÓN DE UNA PILA

Para la simulación de una pila hemos creído convenientedesarrollar el siguiente ejercicio:
Escribir el algoritmo de la empresa “LOS PSS” la cual quiere realizar un formulario de las edades de sus trabajadores en función a pilas

* Diseñar una pila dondese ingrese un tope de 41 edades.
* Verificar que esta pila este vacía.
* Permita ingresar cualquier Edad
* Permita extraer ultima edad ingresada.
* Buscar una edad de un trabajador.* Mostrar su contenido.

ALGORITMO PRINCIPAL

Declarar gcOpcion, PILAEDADES[40], gnTOP,
gnMAX ← 40
gnTOP ← -1

PUSH significa que vamos a ingresar un elemento o en este caso unaedad.
POP significa salida recupera o extrae un elemento
MENU PRINCIPAL
Mostrar “Empresa LOS PSS”
MENU
Leer gcOpcion
Mientras (gcOpcion != “S”) hacer
Según gcOpcion
“1” PUSH

“2” POP“3” BUSCAREDAD

“4” ELIMINAREDAD

“5” IMPRIMIRPILADEEDADES

“S” SALIR
MENU
Leer gcOpcion
Fin mientras
Fin

Tope← 40
00
40
39
38
37
.
.
.
3
2

1
PROCEDIMIENTOMENU
Mostrar “Simulación de una PILA”
Mostrar “1 Inserte edad (PUSH)”
Mostrar “2 Eliminar (POP)”
Mostrar “3 Buscar Edad”
Mostrar “4 Eliminar Edad”
Mostrar “5 Imprimir Pila”
Mostrar “S Salir”FIN PROCEDIMIENTO

PROCEDIMIENTO PUSH ( )
Declarar nEdad, nResultado
Mostrar “Ingrese edad”
Leer nEdad
Si (nEdad >0) entonces
nResultado ← push (PILAEDADES[40], gnTop, gnMax, nEdad)
Si(nResultado==1) entonces
Mostrar “Se ha insertado satisfactoriamente”,
Sino
Mostrar “Insercion fallida”
Sino
Mostrar “error”
Mostrar “ingrese edad valida”
Fin si
Fin procedimiento...
tracking img