Pseudocodigos

Solo disponible en BuenasTareas
  • Páginas : 5 (1207 palabras )
  • Descarga(s) : 0
  • Publicado : 23 de noviembre de 2010
Leer documento completo
Vista previa del texto
Pseudocódigos
Integrantes:
Amador García
Gallegos Valle
Monterd Martínez
Villafán Figueroa

2010
[Escribir el nombre del autor]
[Escribir el nombre de la compañía]
09/06/2010

1.-Introducir un numero por teclado. Que nos diga si es par o impar.

Nombre: Par- Impar
Variables: núm. <- 0
ESCRIBIR "Introduce un número: "
LEER núm.
SI MOD núm. / 2 = 0
ESCRIBIR"es par"
SINO
ESCRIBIR "es impar"
FIN.SI
FIN

2.-Leer 3 números por teclado, si el primero es positivo calcule el producto de los 3 en caso contrario calcule la suma de los 3 números

Nombre: Suma-Producto
Variables:
Entero n1, n2, n3, suma, producto
Inicio
Leer n1, n2, n3
Si n1>0
Producto= n1*n2*n3
Sino
Suma= n1+n2+n3
Fin Si
Fin

3.-Leer 4 numeroenteros desde teclado y calcular la suma

Nombre: Sumatoria
Variables:
Entero n1, n2, n3, n4, suma
Inicio
Leer n1, n2, n3, n4, suma
Suma= n1+n2+n3+n4
Fin

6.-Imprimir los números del 0 al 100

Nombre: Imprimir 100 números
Variables:
Entero c=0
Inicio:
Hacer mientras( c <=100)
“ESCRIBIR” c
c= c + 1
FIN hacer
FIN

7.-Imprimir los números del 100 al 0Nombre: Imprimir números
c=100
Inicio:
Hacer mientras( c >=100)
“ESCRIBIR” c
c= c - 1
FIN hacer
FIN

8.-Hacer un pseudocódigo que imprima los números pares entre 0 y 100.

Nombre: Imprimir pares
Variables:
Entero:
c = 2
Hacer mientras(c <=100)
“ESCRIBIR” c
c = c + 2
FIN hacer
FIN

9.- Hacer un programa que imprima la suma delos 100 primeros números.

Nombre: suma
Variables:
c = 1
suma = 0
Inicio:

Hacer mientras (c <= 100)
suma = suma + c
c = c + 1
FIN hacer
ESCRIBIR "La suma de los 100 primeros números es: "
ESCRIBIR suma
FIN

10.-Hacer un pseudocódigo que imprima los números impares hasta el 100 y que Imprima cuantos impares hay.

Nombre: Impares
Variablesc = 1
son = 0
Inicio:
Hacer mientras (c <= 100)
ESCRIBIR c
c = c + 2
son = son + 1
FIN hacer
ESCRIBIR "El número de impares: "
ESCRIBIR son
FIN

11.-Imprimir los números impares desde el 100 al 1 y calcular la suma

Nombre: Imprimir impares desde 100
Variables:
c=100
Hacer mientras (c>=0)
Si (n MOD /2 <> 0)
Escribir “n”suma = suma + c
Fin Si
c = c+1
Fin hacer
Fin

13.- y contar los múltiplos de 3 desde la unidad hasta un número queIntroducimos por teclado.

Nombre: múltiplos 3
Variables:
i = 3
n = 0
c = 0
Inicio:
ESCRIBIR "Número: "
LEER n
Hacer mientras (i <= n)
SI i = int (i / 3) * 3 ENTONCES
ESCRIBIR i
c = c + 1
FIN Si
i = i + 1FIN hacer
ESCRIBIR "El número de múltiplos de 3 son: "
ESCRIBIR c
FIN

14.- Hacer un pseudocódigo que imprima los números del 1 al 100. Que calcule la suma de todos los números pares por un lado, y por otro, la de todos los
Impares.

Nombre: par impar
Variables:
i = 1
sumapar = 0
sumaimp = 0
Inicio:
MIENTRAS i < 101 HACER
SI i = int ( i / 2 ) * 2ENTONCES
sumapar = sumapar + i
SINO
sumaimp = sumaimp + i
FINSI
i = i + 1
FIN hacer
ESCRIBIR "La suma de los pares es: "
ESCRIBIR sumapar
ESCRIBIR "La suma de los impares es: "
ESCRIBIR sumaimp
FIN

15.-Hacer un pseudocódigo que imprima el mayor y el menor de una serie de cinco números que vamos introduciendo por teclado.

Nombre: mayormenor
Variables:
con = 0
n = 0
máximo = 0
mínimo = 99999
Inicio:
Hacer mientras (con <= 5)
ESCRIBIR "Número: "
LEER n
SI n > maximo ENTONCES
maximo = n
FIN SI
SI (n < minimo) ENTONCES
minimo = n
FIN Si
con = con + 1
FIN hacer
ESCRIBIR "El mayor de los números es: "
ESCRIBIR maximo...
tracking img