Guia algoritmos

Solo disponible en BuenasTareas
  • Páginas : 6 (1397 palabras )
  • Descarga(s) : 0
  • Publicado : 25 de noviembre de 2010
Leer documento completo
Vista previa del texto
Guía Uno - Algoritmos

Representación de variables
Cuando representamos datos, numéricos o alfanuméricos, debemos darles un nombre. Una variable es un nombre que representa el valor de un dato. En esencia, una variable es una zona o posición de memoria en la computadora donde se almacena información. En un pseudocódigo y también en un programa se pueden crear tantas variables como queramos.Ejemplos:
* A = 50; Variable tipo numérica A cuyo valor es 50.
* Ciudad = "Asunción"; Variable alfanumérica o de tipo carácter Ciudad, cuyo  valor es "Asunción"
* X = C + B; Variable numérica X cuyo valor es la suma de los valores de las variables numéricas C y B. (Nota: C y B deben tener algún valor).
Existe otra forma de asignar un valor a una variable, a través de la instrucciónleer:
Leer (Nombre_variable)
Esta instrucción pide al usuario un valor que será asignado a la variable Nombre_variable, es decir, en Nombre_variable se almacena el valor ingresado por el usuario.

Todas la variables deben de declararse antes de ser utilizadas. Debemos declarar las variables utilizando el siguiente formato:
Nombre_variable Tipo (numérica o texto)
Ejemplos:
* nombre Texto* Edad, peso numero (observe que podemos declarar varias variables en una misma línea, siempre y cuando sean del mismo tipo)

 Asignación
Para asignar un valor a una variable se utilizará el símbolo = que en este contexto significa “es reemplazado por”. De forma general tendremos que:
Nombre_variable = expresión
El valor de Nombre_variable se sustituye por el valor de expresión
Ejemplos:* C = 13
* B = 25
* X = C + B       (después de estas instrucciones, X contendrá el valor 13 + 25 = 38) 
 
Operadores de relación
Los operadores relacionales se utilizan para formar expresiones que al ser evaluadas producen un valor de tipo lógico: verdadero o falso.
 
Signo | Operador |   | Ejemplo | Resultado |
> | Mayor que |   | 25 <= 25 | Verdadero |
< | Menorque |   | 25 <> 25 | Falso |
== | Igual a |   | 25 <> 4 | Verdadero |
<= | Menor o igual que |   | 50 <= 100 | Verdadero |
>= | Mayor o igual que |   | 500 >= 1 | Verdadero |
<> | Distinto |   | 1 = 6 | Falso |
 Operadores aritméticos
 
Signo | Significado |
+ | Suma |
- | Resta |
* | Multiplicación |
/ | División |
^ | Potenciación |
MOD |Resto de la división entera |
 
Estructuras de selección
El formato de la estructura de selección es:
 
si  (condición) entonces
            instrucción 1
 instrucción 2
  ...................
            instrucción n
 si no
            instrucción a
            instrucción b
            ...................
            instrucción z
fin si
 
El resultado de evaluar lacondición puede ser verdadero o falso: en el caso de que sea verdadero, se ejecutarán: instrucción 1,  instrucción 2, ... , instrucción n. Si el resultado de evaluar condición es falso se ejecutarán: instrucción a,  instrucción b, ... , instrucción z.  
 
Ejemplo:
Si A = 5 entonces
Imprimir("A es 5")
si no
            imprimir("A no es igual a 5")
fin si
 

en el caso que variable
sea elvalor
instrucción a
………………….
sea el valor
instrucción b
……………………

En cualquier otro caso
Error
fin caso

Estructuras de repetición
 
MIENTRAS:

mientras (condición)
instrucción 1
instrucción 2
.....
instrucción n
fin mientras
 
El resultado de evaluar condición puede ser verdadero o falso:
Mientras sea verdadero, se ejecutarán: instrucción 1,  instrucción 2, ..., instrucción n. Estas instrucciones dejarán de ejecutarse cuando condición sea falso.

Ejemplo:
leer(contraseña)
mientras (contraseña < > "joshua")
imprimir("La contraseña es incorrecta !")
leer (contraseña)
fin-mientras
imprimir("Ha tecleado la contraseña correcta")

Nota: El bucle se repetirá mientras que contraseña <> “joshua” sea verdadero
 
HASTA QUE:
ejecutar 1...
tracking img