Yenika espinel

Solo disponible en BuenasTareas
  • Páginas : 4 (785 palabras )
  • Descarga(s) : 0
  • Publicado : 10 de septiembre de 2010
Leer documento completo
Vista previa del texto
CICLOS PROBLEMAS REPETITIVOS

CICLO MIENTRAS QUE

Nos permite repetir un grupo de instrucción es un numero de veces determinada, dentro de un mismo algoritmo.

• Variable contador:permite controlar (contar) cuantas veces se realiza el ciclo dentro del dentro del algoritmo.

• Variables más utilizadas: cont, i, j, k, c.

• Variables acumuladoras. Permite acumularvalores en los ciclos, para luego utilizar el valor allí almacenado.

Ejemplos:

1. Hacer el dfd y el pseudocódigo que permita leer 10 números y calculare el valor de la suma.

PSEUDOCÓDIGO:Inicio

Var en: num

Var sal: Sum

Var aux: Cont

Cont 0

Sum 0

Mientras que (Cont < 10) hacer

Leer (num)

Sum Sum + num

Cont Cont + 1

Fin mientrasEscribir (Sum)

Fin

2. Hacer el dfd leer las edades de 7 personas y calcular el promedio de edad.

DFD:

3. Hacer el dfd y el pseudocódigo que permita calcular la sumatoria de los números del 1al 10.

DFD:

4. Hacer el dfd que permita calcular el promedio de edad de las mujeres y el promedio de edad de los hombres de un grupo de N personas.

Nota: hay hombres y mujeres.

DFD:No Si

5. Hacer el dfd y seudocódigo que permita leer los días trabajados de X trabajadores y calcular el sueldo de cada uno teniendo en cuenta que si trabaja menos de 3 días se le descuenta un 5 %calcular también el valor de todos los sueldos pagados. Valor día 15000

DFD:

SEUDOCÓDIGO:

Inicio

Var en: x, ND

Var sal: Suel, VT

Var aux: Cont, D

Cont 0

Sum 0Leer (x)

Mientras que (cont < x) hacer

Leer (ND)

Si (ND < 30) entonces

D (15000 * ND) * 0.05

Sino

D 0

Fin si

Suel (ND * 15000) – D

VT VT + Suel

ContCont + 1

Escribir (Suel)

Fin mientras

Escribir (VT)

Fin

CICLO PARA

Ejemplos:

1. hacer el dfd y el seudocódigo que permita leer los sueldos de 8 personas y calcular la suma...
tracking img