Algoritmos de metodos numericos

Solo disponible en BuenasTareas
  • Páginas : 12 (2925 palabras )
  • Descarga(s) : 0
  • Publicado : 15 de mayo de 2011
Leer documento completo
Vista previa del texto
SOLUCION DE ECUACIONES TRASCENDENTES

METODO DE BISECCIONES SUCESIVAS

La representación del método se tiene a continuación:

[pic]

El algoritmo del método es:

Inicio
Definir f(x)
Leer x1, x2, ε

Repetir
xmed = [pic]
Si f(x1) f(xmed) < 0 entonces
x2 = xmed
Si_no
x1 = xmed
Fin_si
Hasta |x2 – x1| < ε
raiz = [pic]
Imprimir raizTerminar

METODO DE FALSA POSICIÓN

Para que tenga convergencia el método, es suficiente que se cumpla con las siguientes condiciones:

( i ) f(x1) f(x2) < 0
( ii ) f(x1) f”(x1) > 0
( iii ) f”(xi) ≠ 0 [pic] xi [pic][x1, x2]

Recuérdese que si f”(x) > 0, la concavidad es hacia arriba; si f”(x) < 0, la concavidad es hacia abajo. Por lo tanto, las condiciones tienen el siguientesignificado:

( i ). Significa que hay una raíz en el intervalo. Al menos una; ya que pueden haber raíces múltiples, pero en una cantidad impar. La posibilidad de raíces múltiples se anula si la función y = f(x) es monótona en un intervalo trabajado.

( ii ). Asegura que se tome el punto x1 (el pivote) de manera adecuada. Tomar de manera inadecuada el pivote podría provocar unadivergencia en la sucesión generada.

( iii ). Asegura que no se dé un caso extremo de divergencia. Este caso provocaría una divergencia en la sucesión y se debe al hecho de encontrarse más de una raíz en el intervalo o un cambio de concavidad.

El Algoritmo del método es:

Inicio

Definir f(x)
Leer x1, x2, ε

Repetir
xi = [pic]
delta = |x2 – xi|
x2 = xiHasta delta < ε
raiz = xi
Imprimir raiz
Terminar

METODO DE NEWTON-RAPSHON

La representación gráfica del método es:

[pic]

A continuación tenemos el algoritmo estructurado para el método de Newton – Raphson:

Inicio

Definir f(x)
Leer x, ε
Repetir
xi = [pic]
delta = |x – xi|
x = xi
Hasta delta < ε
raiz = xi
Imprimir raizTerminar

SOLUCION DE ECUACIONES POLINOMIALES

METODO DE BIRGE-VIETA

El método tiene el siguiente procedimiento:

1. Escribir la ecuación en orden descendente de potencias de x.
2. Separar las raíces nulas.
3. Aplicar la regla de los signos de Descartes.
4. Establecer las posibles raíces racionales.
5. Probarlas por división sintética o teorema del resto.
6.Sacar las raíces irracionales.
7. Reducir la ecuación y volver al paso 6, hasta hallar todas las raíces.

A continuación se presenta el algoritmo estructurado para el método

Inicio

Leer grado, ε
m = grado + 1
Para i = 1 hasta m
Leer ai
fin_para

Para raices = 1 hasta grado
x = 1
Repetir
b1 = a1
Para i = 2 hasta m
bi = ai + x * bi-1fin_para
c1 = b1
Para i = 2 hasta m-1
ci = bai + x * ci-1
fin_para
xi = [pic]
delta = |x1 – x|
x = x1
Hasta delta < ε
Imprimir raices, x
Terminar

SOLUCION DE SISTEMAS DE ECUACIONES

METODO DE GAUSS-JORDAN

Este método se basa en la aplicación de las transformaciones elementales de filas y puede emplearse para encontrar lainversa de matrices y resolver sistemas de ecuaciones lineales.

A continuación se tiene el algoritmo del método:

Inicio
Leer n
m = n + 1
Para i = 1 hasta n
Para j = 1 hasta m
Leer aij
fin_para
fin_para
Para i = 1 hasta n
Pivote = aij
Para j = 1 hasta m
aij = aij/pivote
fin_para
Para k = 1 hasta n
Si k ≠ i entonces
cero = akiPara j = 1 hasta m
akj = akj - cero * aij
fin_para
fin_si
fin_para
fin_para
Para i = 1 hasta n
Imprimir aim
fin_para
Terminar

METODO DE JACOBI

Es un método iterativo y para que tenga convergencia, es necesario que el elemento de la diagonal de la matriz del sistema en valor absoluto sea mayor que la suma de los valores absolutos de los...
tracking img