Nassi-shneiderman

Solo disponible en BuenasTareas
  • Páginas : 3 (564 palabras )
  • Descarga(s) : 0
  • Publicado : 7 de noviembre de 2010
Leer documento completo
Vista previa del texto
Diagramas Nassi-Schneiderman Los diagramas Nassi-Schneiderman son una técnica para la especificación de algoritmos que combina la descripción textual del pseudocódigo con la representación gráficadel diagrama de flujo. Todo algoritmo se representa de la siguiente forma:

Existe una representación para cada una de las 3 instrucciones permitidas en la programación estructurada. • Secuenciales.Recordemos que aquí tenemos: declaración de variables (tipo: nombre_variable), asignación (nombre_variable = valor), lectura (Leer ) y escritura de datos (Escribir ).



Alternativas. oAlternativa simple.

o Alternativa doble

o Alternativa múltiple



Iterativas. o Ciclo Mientras

o Ciclo Repetir

o Ciclo Desde / Para



Alternativas anidadas. Consta de una serie deestructuras si, unas interiores a otras; a su vez, dentro de cada estructura pueden existir diferentes acciones. Se utiliza para diseñar estructuras que contengan más de dos alternativas.

•Iterativas anidadas. Consta en anidar un ciclo dentro de otro. En este caso la estructura interna debe estar incluida totalmente dentro de la externa y no puede existir solapamiento.

Ejemplos: Elabora unasolución, la más conveniente, para calcular el valor de la suma 1 + 2 + 3 + … + 100, utilizando la estructura mientras (algoritmo visto en clase). algoritmo suma_1_a_100 var entero: contador, SUMAinicio contador ← 1 SUMA ← 0 mientras contador N write (‘La suma es:’, SUMA) end

Elabora una solución, la más conveniente, para calcular el factorial de un número N (N! = N * (N – 1) * (N – 2) * … *3 * 2 * 1). algoritmo factorial var entero: i, N, FACTORIAL inicio leer (N) si N < 0 entonces escribir (‘El número dado debe ser positivo.’) si_no FACTORIAL ← 1 Si N > 1 entonces desde i ← 2 hasta Nincremento 1 hacer FACTORIAL ← FACTORIAL * i fin_desde fin_si escribir (‘El factorial de’, N, ‘es:’, FACTORIAL) fin_si fin algoritmo factorial var entero: i, N, FACTORIAL begin read (N) if N < 0...
tracking img