Open office

Solo disponible en BuenasTareas
  • Páginas : 8 (1940 palabras )
  • Descarga(s) : 0
  • Publicado : 10 de diciembre de 2010
Leer documento completo
Vista previa del texto
Sobre este artículo En este artículo encontrarás algunos apuntes sobre OpenOffice.org Calc a través de un ejemplo práctico. La hoja de cálculo resultante muestra una lista de notas de varios alumnos en tres exámenes diferentes, calculando para cada uno de ellos la nota media final y resaltando en rojo y de forma automática los suspensos.
Imagen:Paso12.png
--Enrique 18:44 10 ene 2010 (UTC)El entorno Calc Imagen:Calc_entorno.png
Un ejemplo sencillo Supongamos que hemos realizado tres exámenes en alguna de las asignaturas y queremos calcular la media aritmética de las notas obtenidas en cada una de ellas. Para ello, en primer lugar introducimos en tres celdas distintas (B6, C6 y D6) cada una de las notas.
Imagen:Calc_paso01.png
Operaciones básicas La operaciones básicas en Calccorresponden con las operaciones matemáticas por todos conocidas: suma (+), resta (-), multiplicación (*) y división (/). Con estos operadores podríamos realizar ya un cálculo básico en una de las celdas, como por ejemplo, hallar el promedio de las tres notas introducidas en las celdas B6, C6 y D6.
Para ello nos situamos en la celda E6 e introducimos la siguiente fórmula:
=(B6+C6+D6)/3Imagen:Calc_paso02.png
Podemos comprobar como al cambiar alguno de los valores en las celdas B6, C6 o D6, el valor de la celda E6 (el que muestra la media aritmética) se vuelve a calcular automáticamente.
Operadores aritméticos Operador | Descripción | Ejemplo |
+ | Suma | =A1+B1 |
- | Resta | =B2-A2 |
* | Multiplicación | =C3*C4 |/ | División | =A1/B3 |
^ | Exponenciación | =A2^B3 |

Funciones Las funciones tienen, en otros propósitos, el de facilitar determinados cálculos que suelen ser habituales, como el de la suma de una lista de valores, el máximo o mínimo de un conjunto de números o el promedio de una serie de valores, como es el caso que nos ocupa.
Función SUMA Para el casoanterior del cálculo de la media aritmética de los 3 exámenes, podemos utilizar sin mayor problema el operador + para sumar los valores, puesto que sólo son 3. Sin embargo, imaginemos que debemos sumar una lista de 500 números. Supondría muchísimo trabajo escribir cada uno de los números separados por un signo +. Para ello disponemos en Calc de la función SUMA, que permite sumar una serie de valores.Para el ejemplo anterior podríamos reescribir la fórmula del siguiente modo:
=SUMA(B6:D6)/3
Imagen:Calc_paso03.png
Como se puede observar hemos sustituido parte de la fórmula (B6+C6+D6) por la suma de un intervalo de celdas, es decir, la suma de los valores que van desde la celda B6 hasta la celda D6, y este intervalo lo indicamos con el carácter “dos puntos” (:).
Función PROMEDIOAfortundamente Calc cuenta con la función PROMEDIO, que facilita aún más la tarea de calcular la media aritmética de varios valores numéricos, que se pueden expresar también con un intervalo de celdas.
=PROMEDIO(B6:D6)
Imagen:Calc_paso04.png
Toma de decisiones: funciones condicionales Supongamos que deseamos calcular la nota media (con la función PROMEDIO), pero con cierta condición, por ejemplo sólosi el alumno ha aprobado los dos primeros exámenes, es decir, si la nota de los exámenes 1 y 2 es mayor o igual que 5. Para ello disponemos en Calc de funciones lógicas como la función SI que nos permite mostrar un valor u otro en una celda dependiendo de si se cumple una condición o no.
Función SI La función SI tiene esta forma:
=SI( <condición>; <valor-si-verdadero>;<valor-si-falso> )
Como se puede observar la función SI consta de 3 partes:
<condición> es una expresión lógica que puede ser verdadera (V) o falsa (F). Por ejemplo: B6>=5 (B6 es mayor o igual que 5).
<valor-si-verdadero> es el valor que muestra la celda en caso de que la condición se cumpla.
<valor-si-falso> es el valor que muestra la celda en caso de que la...
tracking img