Programacion

Solo disponible en BuenasTareas
  • Páginas : 2 (443 palabras )
  • Descarga(s) : 0
  • Publicado : 9 de noviembre de 2010
Leer documento completo
Vista previa del texto
ALGORITMOS RESUELTOS

--------------------------------------------------------------------------

TEMA 1

--------------------------------------------------------------------------

BUCLES YTOMAS DE DECISIÓN

--------------------------------------------------------------------------

1.-Hacer un pseudocódigo que imprima los números del 1 al 100.

PROGRAMA contador1
ENTORNO:
c← 0
ALGORITMO:
//
MIENTRAS c < 101 HACER
ESCRIBIR c
c ← c + 1
FINMIENTRAS
FINPROGRAMA

--------------------------------------------------------------------------2.-Hacer un pseudocódigo que imprima los números del 100 al 0, en orden decreciente.

PROGRAMA contador2
ENTORNO:
c ← 100
ALGORITMO:
//
MIENTRAS c = num2 HACER
ESCRIBIR num1son ← son + 1
SI num1 = int( num1 / 2 ) * 2 ENTONCES
pares ← pares + 1
SINO
sumaimpa ← sumaimpa + num1
FINSI
num1 ← num1 + 1
FINMIENTRASESCRIBIR "N£meros visualizados: "
ESCRIBIR son
ESCRIBIR "Pares hay: "
ESCRIBIR pares
ESCRIBIR "La suma de los impares es: "
ESCRIBIR sumaimpa
FINPROGRAMA--------------------------------------------------------------------------
TEMA 2
--------------------------------------------------------------------------
BUCLES ANIDADOS Y SUBPROGRAMAS--------------------------------------------------------------------------

16.-Imprimir diez veces la serie de números del 1 al 10.

PROGRAMA diez
ENTORNO:
serie ← 0
ALGORITMO:
//
MIENTRAS serie = 1000 HACEREN 15,col ESCRIBIR "M"
num ← num - 1000
col ← col + 1
FINMIENTRAS
SI num >= 900 ENTONCES
EN 15,col ESCRIBIR "CM"
num ← num - 900
col ←col + 2
FINSI
SI num >= 500 ENTONCES
EN 15,col ESCRIBIR "D"
num ← num - 500
col ← col + 1
FINSI
MIENTRAS num >= 100 HACER
EN 15,col...
tracking img