Introduccion

Solo disponible en BuenasTareas
  • Páginas : 2 (428 palabras )
  • Descarga(s) : 0
  • Publicado : 25 de agosto de 2012
Leer documento completo
Vista previa del texto
HACER UN PROGRAMA EN UNA MATRIZ QUE PERMITA INGRESAR Y ALMACENAR Y MOSTRAR LOS APELLIDOS DE SEIS ALUMNOS DE LA FIA Y LAS 3 PRIMERAS LETRAS DE CADA APELLIDO

ANALISIS
Matriz
Alumnos:6Apellido= ape
LEER ape
ALMACENAR APELLIDOS: m[i][j]=ape
ALMACENAR LAS TRES PRIMERAS LETRAS DEL APELLIDO: sm[i][j]=v[i][j].SUBCADENA (0,3);

DIAGRAMA DE FLUJOINICIO

ENTERO tam
TEXTO ape
TEXTO m[ ] [ ] , sm[ ] [ ]

CREAR m[6] [1] , sm[6] [1]


ENTERO i=0

i<6

ENTERO j=0

I=i+1
J<1

ape

tam=ape.LONGITUD()

j=j+1Tam<3

m[i] [j]=ape

ENTERO i=0

i<6

ENTERO j=0

i=i+1
J<1

sm[i][j]=m[i][j].SUBCADENA(0,3);

j=j+1

m[i][j] , sm[i][j];

PSEUDOCODIGO
ALGORITMO_PRGMATRIZ

ENTRADA: apeSALIDA: m[i][j], sm[i][j]

ENTERO i, j, tam
TEXTO m[ ][ ], sm[ ][ ]
TEXTO ape
CREAR m[ 6][1 ], sm[6 ][1 ]
PARA (i=0; i<6; i++) HACER
PARA (j=0; j<1; j++) HACERHACER
LEER ape
tam= ape.LONGITUD()
SI (tam<3) ENTONCES
ESCRIBIR error
FINSI
MIENTRAS (tam<3)m[i][j]=ape
FINPARA
FINPARA
PARA (i=0; i<6;i++) HACER
PARA (j=0; j<1;j++)HACER
sm[i][j]=m[i][j]. SUBCADENA (0,3);
FINPARA
FINPARA
ESCRIBIRapellido, tres letras

PARA (i=0;i<6;i++) HACER
PARA (j=0;j<1;j++) HACER
ESCRIBIR m[i][j], sm[i][j];
FINPARA
ESCRIBIR SALTO DE LINEA
FINPARA
FIN

PROGRAMA C++

#include<cstdlib>
#include <iostream>
using namespace std;

int main(int argc, char *argv[])
{
int i,j,tam;
string m[6][1], sm[6][1] ;
string ape;

for(i=0;i<6;i++){for(j=0;j<1;j++){
do{
cout<<"ingrese apellido:"<<endl;
cin>>ape;
tam=ape.length();
if(tam<3){...
tracking img