Liderazgo

Solo disponible en BuenasTareas
  • Páginas : 5 (1204 palabras )
  • Descarga(s) : 4
  • Publicado : 10 de mayo de 2010
Leer documento completo
Vista previa del texto
Cómo hacer un TEST AUTOCORREGIBLE con Microsoft Excel

Un test auto-corregible es una herramienta que, enfocada de un modo adecuado, permite al alumno evaluar su progreso en la asignatura y detectar aquellos conceptos que han sido menos asimilados o que presentan mayor dificultad.

La forma más sencilla de realizar un test autocorregible es mediante una batería de preguntas, con suscorrespondientes múltiples respuestas, que después se comparan con una plantilla. Sin embargo, esto supone la creación, cada vez que queremos realizar un nuevo test, de las preguntas, las respuestas y la plantilla.

Lo que vamos a conseguir utilizando una herramienta TIC como Microsoft Excel es crear una plantilla de test que posteriormente podremos modificar de forma rápida y sencilla paracrear nuevos tests.

1. Creación de la batería de preguntas y respuestas.

Esta es la parte más sencilla. Se trata de escribir las preguntas y las respuestas distribuidas en celdas. Por ejemplo, como en la siguiente figura:

[pic]

En esta plantilla, las celdas A1:G1 se han combinado para crear una sola celda de título. Los pasos son los siguientes:
a) Seleccionar el rango A1:G1.
b)Pulsar el boton derecho y, en el cuadro de diálogo seleccionar Formato de celdas.
c) Seleccionar la pestaña Alineación y elegir Combinar celdas.

Las preguntas se escriben en las celdas B (B10; B17 y B18; etc.…). Hasta un total de 10 preguntas (no se muestran todas). Para escribir las preguntas no se han combinado celdas, simplemente se escribe y el texto aparecerá sobre las celdassiguientes. Hay que tener cuidado de no extenderse demasiado en una línea para que no desaparezca de la primera página. Se puede comprobar pulsando el icono:

[pic]

En cualquier caso, se puede utilizar el modelo test_autocorregible.xls y modificarlo.

Las celdas coloreadas de rojo y verde, son las que nos indicarán si la respuesta es correcta o falsa.

2. Funciones lógicas

Una vez hemos escritolas preguntas y las respuestas hemos de introducir las funciones adecuadas para que Excel nos corrija el test.

Empezamos escribiendo FALSO en la casilla I4 y CORRECTO en la casilla I5, tal y como se muestra en la figura:

[pic]

No es necesario que sean las celdas I4 e I5, podrían ser cualesquiera otras. Sólo tienen que cumplir una condición: tienen que estar suficientemente separadas delas preguntas y respuestas para que luego podemos ocultarlas sin deshacer el test.

Lo siguiente que tenemos que hacer es escribir en la celda I12 (también la elección es opcional, pero es aconsejable nos permite visualizar las preguntas y no se nos monta con el test) la siguiente fórmula:

=SI(D14="x";I$5;I$4)

Esta es una función condicional que nos devuelve el valor de I5 si en D14 hay unax y el valor de I4 en caso contrario. Los símbolos $ se utilizan para que, más tarde, al copiar y pegar no se modifiquen las celdas a las que hacemos referencia (I4 e I5). En el lugar en el que hemos puesto D14, debe ir la celda que corresponde a la respuesta correcta. Se debe cambiar si en nuestro test la respuesta esta en otra celda (D12, D13 o D15).

A continuación escribimos en I13 lasiguiente fórmula:

=SI(E$82="comprobar";CONTAR.SI(D12:D15;"x");"")

Aquí tenemos dos funciones condicionales: SI y CONTAR.SI. Además se encuentran anidadas. Esta fórmula hace lo siguiente: si el valor de E82 es el texto comprobar entonces ejecuta la siguiente función y en caso contrario, la celda permanece en blanco. Si se ejecuta la función CONTAR.SI, ésta cuenta las celdas en el rango D12:D15que cumplen la condición asignada, en este caso contener una x.

El siguiente paso es escribir en I14:

=SI(I13=1;SI(I12=I$5;1;-0,33);0)

De nuevo encontramos dos funciones condicionales anidadas. El funcionamiento es el siguiente: el SI más externo, cuando la celda I13 tiene el valor 1 (lo que sucede cuando hemos respondido), entonces ejecuta el SI más interno y en caso contrario nos...
tracking img