Matrices

Solo disponible en BuenasTareas
  • Páginas : 3 (642 palabras )
  • Descarga(s) : 4
  • Publicado : 2 de junio de 2010
Leer documento completo
Vista previa del texto
Juan Sebastian Osorio Velasuqez
1. Se tiene una matriz de 5 filas y 10 columnas. Realice un algoritmo que muestre la última fila.

Inicio
Entero Matriz [5][10]
Entero i,j

Para i=0hasta 4
Para j=0 hasta 9
Si (i=4)
Mostrar “la ultima fila es” Matriz [i][j]
Sino
Fin siFin para
Fin para

2. Se tiene una matriz de 10 filas y 8 columnas. Realice un algoritmo que muestre la primera columna.

Inicio
Entero Matriz [10][8]
Entero i,jPara i=0 hasta 9
Para j=0 hasta 7
Si (j=0)
Mostrar “la primera columna es” Matriz [i][j]
SinoFin si
Fin para
Fin para

3. Se tiene una matriz de orden 5. realice un algoritmo que muestre la diagonal principal.

Inicio
Entero Matriz [5][5]
Entero i,j

Parai=0 hasta 4
Para j=0 hasta 4
Si (i=j)
Mostrar “la diagonal principal es” Matriz [i][j]
SinoFin si
Fin para
Fin para

4. Se tiene una matriz de orden N. realice un algoritmo que muestre la diagonal secundaria.

Inicio
Lea n
Entero Matriz [n][n]
Entero i,jPara i=0 hasta n,-1
Para j=0 hasta n,-1
Fin para
Fin para
Para i=0 hasta n,-1
Para j=n hasta 0,-1
Mostrar “ladiagonal secundaria es” Matriz [i][j]
i=i+1

Fin para
Fin para

5. Se tiene una matriz de M x N. Realice un algoritmo que muestre la suma de cada una delas filas, cuál fila es la mayor y cuál fila es la menor.

Inicio
Lea M,N
Entero Matriz [M][N],Vector[M]
Entero i,j,suma=0
Para i=0 hasta M,-1
Para j=0 hasta n,-1...