Programacion

Solo disponible en BuenasTareas
  • Páginas : 13 (3077 palabras )
  • Descarga(s) : 0
  • Publicado : 19 de febrero de 2012
Leer documento completo
Vista previa del texto
Objetivo del curso: Analizar, diseñar, desarrollar e implementar soluciones de problemas utilizando estructuras condicionales, repetitivas y arreglos en un lenguaje de programación.

Temario:
1. Conceptos Básicos
* Clasificación del SW.
* Algoritmo.
* Lenguaje de Programación.
* Programa.
* Programación.
* Paradigmas de programación.
* Editores de texto.
*Compiladores.
* Ejecutables.
* Interfaz de línea de comando.
2. Algoritmos
* Análisis de problemas.
* Representación de algoritmos.
* Diseño de algoritmos.
3. Introducción a la programación
* Características del lenguaje de programación.
* Estructura básica de un programa.
* Traducción de un programa.
* Ejecución de un programa.
* Elementos dellenguaje.
4. Control de flujo
* Estructuras secuenciales.
* Estructuras selectivas.
* Estructuras iterativas.
5. Arreglos
* Unidimensionales.
* Multidimensionales.

PREGUNTAS Y RESPUESTAS

1. ¿Qué es un algoritmo?
2. ¿Cómo puedo representar y diseñar un algoritmo?
3. ¿Qué es un programa?
4. ¿Cuál es la estructura básica de un programa?
5. ¿Dónde y cómopuedo escribir un programa de computadora?
6. ¿Qué es y para qué sirven los lenguajes de programación?
7. ¿Cuál es la historia de los lenguajes de programación?
8. ¿Cómo se clasifican los lenguajes de programación?
9. ¿Cómo reconoce una computadora las instrucciones de un programa para ser ejecutadas?
10. ¿Cómo puedo ejecutar un programa de computadora?
11. ¿Cuáles son lasestructuras de control de flujo en un programa y para qué sirven?
12. ¿Cuáles son las estructuras de datos que se pueden utilizar o crear en un programa y para qué sirven?

EJERCICIOS PRACTICOS PARA RESOLVER MEDIANTE ALGORITMOS
1.

2. Construye un avión de papel paso a paso y en forma ordenada. Luego escribe en orden los pasos, para explicarle a otra persona cómo elaborarlo.3.

4.

5.

6.




7.

EJERCICIOS PRACTICOS PARA RESOLVER MEDIANTE PROGRAMAS DE CÓMPUTO

1) Se posee un monto de dinero de $120, se gasta en supermercado $49,5 y luego en verdulería 12,10. Mostrar el saldo. 

Proceso gasto 
saldo<-120 - 49.5 - 12.10; 
Escribir "Saldo ", saldo; 
FinProceso 

Usar este ejercicio para resaltar la necesidad de lautilización de las variables, ya que este ejercicio se ajusta únicamente para los valores constantes consignados. 

2) Realizar el pseudocódigo para calcular el 15% de un valor constante. 

Proceso 15% 
cal <- 325*.15; 
Escribir "El 15% de 325 es ", cal; 
FinProceso 

3) Modificar el pseudocódigo anterior para que muestre el 15% de un valor ingresado. 

Proceso 15% 
Escribir "Ingrese unnumero"; 
Leer n; 
cal <- n*.15; 
Escribir "El 15% de ",n," es ",cal; 
FinProceso 

4) Calcular el nuevo salario de un obrero si obtuvo un incremento del 25% sobre su salario anterior. 

Proceso sueldo_obrero 
Escribir “Ingrese el Sueldo”; 
Leer sueldo; 
Nuevo<-sueldo*.25+sueldo; 
Escribir “El nuevo sueldo es: “,nuevo; 
FinProceso 

5) Calcular el doble de un número ingresado, aese resultado calcularle el 10% y mostrar ese valor. 

Proceso 10%del doble 
Escribir "Ingrese un numero"; 
Leer n 
doble<-n*2; 
por<-doble*.1; 
Escribir "El 10% del doble de ",n," es ",por; 
FinProceso 

6) Informar en pantalla el promedio de cinco números. 

Proceso promedio_5 
Escribir "Ingrese 5 numeros"; 
Leer n1,n2,n3,n4,n5; 
prom<-(n1+n2+n3+n4+n5)/5 
Escribir"Promedio: ",prom; 
FinProceso 

7) Realizar un algoritmo en el cual se obtenga la siguiente información 2*A + 2*B 

Proceso 2*A+2*B 
Escribir "Ingrese un numero"; 
Leer A; 
Escribir "Ingrese otro numero" 
Leer B; 
cal <- 2*a + 2*b; 
Escribir "Resultado ",cal; 
FinProceso 

8) Resuelva un algoritmo que solucione el problema de calcular el área de un triangulo con la fórmula: AREA =...
tracking img